Estoy intentando instalar el SDK de Android en mi sistema Windows 7 x64.

jdk-6u23-windows-x64.exeestá instalado, pero la configuración del SDK de Android se niega a continuar porque no encuentra la instalación de JDK .

¿Es este un problema conocido? ¿Y hay una solución?

Error SDK

respuesta

Presiona Atrás cuando recibas la notificación y luego Siguiente . Esta vez encontrará el JDK.

CONFIGURACIÓN real:

  • Sistema operativo : Windows 8.1
  • Archivo JDK : jdk-8u11-windows-x64.exe
  • Archivo ADT : installer_r23.0.2-windows.exe

Instale el x64 JDK, y pruebe primero la opción atrás-siguiente, y luego intente configurar JAVA_HOMEcomo dice el mensaje de error, pero si eso tampoco funciona para usted, intente esto:

Haga lo que dice, configure JAVA_HOMEsus variables de entorno, pero en la ruta use barras diagonales en lugar de barras diagonales inversas.

En serio.

Para mí, falló cuando JAVA_HOMEestaba C:\Program Files\Java\jdk1.6.0_31pero funcionó bien cuando estaba C:/Program Files/Java/jdk1.6.0_31- ¡me volvió loco!

Si esto no es suficiente, agregue también al comienzo de la variable de entorno Path %JAVA_HOME%;

Valores actualizados en Variables de entorno del sistema:

  • JAVA_HOME=C:/Program Files/Java/jdk1.8.0_11
  • JRE_HOME=C:/Program Files/Java/jre8
  • Path=%JAVA_HOME%;C:...

Encontré la solución y es maravillosamente estúpida. Descubrí que Android SDK no puede detectar JDK .

Presione el botón Atrás en la pantalla de error del SDK que le indica que el EXE no pudo detectar el JDK. Luego presione Siguiente .

¿Quién hubiera pensado que eso sucedería?

Parece que no funciona sin JDK de 32 bits. Solo instálalo y sé feliz...

En su lugar, descargué el archivo .zip y SDK Manager.exelo ejecuté, y funcionó de maravilla. Tuviste el mismo problema con el .exe de lo contrario.

Advertencia: como mencionó un comentarista, ¡no intente esto en Windows 7! Lo probé con Windows XP de 64 bits.

Como la solución publicada NO funciona para todos (incluidos yo mismo y yo), quiero dejar una nota para aquellos que buscan otra forma (sin piratear el registro, etc.) para resolver esto en un sistema Windows de 64 bits. Simplemente agregue PATH (¡letras mayúsculas!) a sus Variables de entorno y establezca el valor en su JDK-Path.

Agregué JDK a la "Ruta" existente que no funcionó, como no funcionó con JAVA_HOME o la solución "Atrás". Agregarlo a "RUTA" finalmente funcionó.

Espero que esto pueda ser útil para alguien.

Todo lo que necesita son las siguientes dos entradas de registro. Parece como si quien publicó las otras cosas del registro básicamente simplemente copió todas las claves HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoften HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft, lo que obviamente no es una solución ideal porque la mayoría de las claves no son necesarias.

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Development Kit]
"CurrentVersion"="1.6"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Development Kit\1.6]
"JavaHome"="C:\\Program Files\\Java\\jdk1.6.0_23"

Ninguna de estas soluciones funcionó para mí. Lo arreglé cambiando temporalmente el nombre de archivo de C:\Windows\System32\java.exeajava_.exe

Ninguna de las soluciones aquí funcionó para la 64-bitversión.

Poner la JDKruta antes de la c:\windows\system32\ruta en sus variables de entorno resuelve el problema. De lo contrario 32-bit java.exe, se encuentra antes de la 64-bit JDKversión.

Después de leer un par de publicaciones de blog, parece ser una solución aún más fácil haciendo clic en ATRÁS cuando el instalador dice que no pudo encontrar el JDK, y luego simplemente haga clic en SIGUIENTE nuevamente y mágicamente encuentra el JDK. No hay cambios en el registro o volver a descargar, etc.

Agregar la variable de entorno JAVA_HOME (en Variables del sistema ) fue el truco para mí. Hacer clic en los botones "Atrás" y "Siguiente" no funcionó.

Windows 7 Professional x64, JDK 1.7.0_04 (64 bit, no tengo instalada la versión x86)

Creo que el instalador intenta encontrar JDK en una versión específica (¿1.6?) Y si no puede encontrarlo, verifica JAVA_HOME que no estaba configurado en mi caso. Tengo otra computadora (el mismo sistema pero con JDK 1.6 x64) y funcionó sin la variable JAVA_HOME.

No tienes que instalar la versión de 32 bits de JDK :)

Copié el Java.exe de

C:\Windows\System32

para

C:\Windows\SysWOW64

Y funcionó.

Estoy usando Windows 8 de 64 bits.

Esta corrección del registro funcionó de maravilla en mi configuración de Windows 7 x64: http://codearetoy.wordpress.com/2010/12/23/jdk-not-found-on-installing-android-sdk/

Presione Report errory OK. Nextestará habilitado.

Establecer la JAVA_HOMEvariable de entorno en

C:\Program Files\Java\jdk1.7.0_07

en vez de

C:\Program Files\Java\jdk1.7.0_07\bin

me lo arregló.

El tipo de arriba que puso esto: "También experimenté este problema, pero ninguna de las respuestas ayudó. Lo que hice, eliminé la última barra invertida de la variable JAVA_HOME y comenzó a funcionar. Además, recuerde no incluir la carpeta bin en el sendero." De hecho, esta era la respuesta correcta.

Para que este SDK se instale, esto es lo que hice. Estoy ejecutando el último sistema operativo Microsoft Windows 8.

Variables de usuario:

Path C:\Program Files\Java\jdk1.7.0_07\bin

Variables de entorno

Crea estos dos:

CLASSPATH %HOME_JAVA%\jre\lib

HOME_JAVA C:\Program Files\Java\jdk1.7.0_09

Este ya existe, así que solo edite:

Path At this end of WindowsPowerShell\v1.0\ simply add ";C:\Program Files\Java\jdk1.7.0_09"

Esto es lo que hice y funcionó para mí. =)

Intente descargar e instalar la versión comprimida en lugar del instalador .exe.

¡ Además, CORRE COMO ADMINISTRADOR ! Trabajó para mí con corrección de barra invertida.

Tuve el mismo problema y lo resolví instalando la versión x86 del JDK (en Windows XP x64).

Tuve el mismo problema, probé todas las soluciones pero nada funcionó. El problema es que con Windows 7 instalado es de 64 bits y todo el software que está instalando debe ser de 32 bits. Android SDK en sí es de 32 bits e identifica solo JDK de 32 bits. Así que instale el siguiente software.

  1. JDK (32 bits)
  2. Android SDK (al instalar SDK, asegúrese de instalarlo en un directorio que no sea "C:\Program Files (x86)", más probablemente en otra unidad o en el directorio donde se extrae Eclipse)
  3. Eclipse (32 bit) y finalmente ADT .

Lo probé y todo funciona bien.

También experimenté este problema, pero ninguna de las respuestas ayudó. Lo que hice, eliminé la última barra invertida de la variable JAVA_HOME y comenzó a funcionar. Además, recuerde no incluir la carpeta bin en la ruta.

SDK de Android es una aplicación de 32 bits, y requiere el JDK de 32 bits para funcionar... el JDK de 64 bits no le servirá de nada...

1-Simplemente haga lo de la variable de entorno "JAVA_HOME".

2-Haga clic con el botón derecho en Android SDK y desde la pestaña compatible, seleccione Windows 7 y administrador.

3-Ejecutarlo de nuevo.

SOLUCIÓN DE TRABAJO Y NO SE NECESITA MODIFICAR EL REGISTRO

Simplemente coloque su ruta de bin de Java delante de su entorno PATH.

RUTA antes

C:\Windows\system32;C:\Windows\%^^&^&^............(old path setting)

RUTA después

C:\Program Files\Java\jdk1.6.0_18\bin;C:\Windows\system32;C:\Windows\%^^&^&^............(old path setting)

Y ahora el instalador de Android SDK está funcionando.

Por cierto, estoy ejecutando Win7 x64.

Sí, instale la versión de 32 bits de Java SE SDK (o cualquiera de las combinaciones). Eso debería ayudar a resolver tu problema.

Para installer_r21.1-windows.exe en Windows 8 x 64, lo que funcionó para mí fue configurar mi variable de entorno de usuario JAVA_HOME en C:\Program Files\Java\jdk1.7.0_10. ¡Espero que esto les ayude a todos! :)

Deberá descargar la versión SDK de 32 bits porque Win7 de 64 bits no es compatible, solo Windows Server 2003 tiene una versión compatible de 64 bits. Durante la descarga de Java SDK, elija "Windows" como su plataforma y no "Windowsx64".
Una vez que hice este Android SDK instalado a la perfección. Espero que esto ayude.

Estoy ejecutando una versión de 64 bits de Windows 7 y estaba teniendo este problema al intentar instalar Android Studio 1.0 usando el ejecutable de:

http://developer.android.com/tools/studio/index.html

Probé todas las soluciones enumeradas y varias versiones diferentes de JDK 1.7 y 1.8, sin dados. Fui con la instalación de la versión comprimida de la aplicación y funcionó a la perfección:

http://tools.android.com/download/studio/canary/latest

Todavía desconcertado por este problema; especialmente porque las versiones beta de Android Studio funcionaron bien.

Los métodos anteriores no me funcionaron en Windows 8 Pro.

Simplemente establezca el camino a

C:\Program Files\Java\jdk1.7.0_07\

Donde C es su unidad en la que ha instalado el JDK.

No olvides la barra inclinada hacia atrás al final.

Probé varias soluciones publicadas y luego tuve que reiniciar el sistema antes de que comenzara a funcionar, lo que puede deberse a que acababa de instalar el JDK. Aquí están todas las cosas que tenía en marcha, no estoy seguro de cuáles eran esenciales:

  • JDK de 64 bits instalado.
  • JAVA_HOME definido usando barras diagonales (/) en lugar de barras diagonales inversas ().
  • El directorio 'bin' de JDK aparece al principio de PATH.
  • Reinicio del sistema.